What are the software requirements for the Dexcom Update Tool?

The Dexcom Update tool is compatible with the following:
Windows
  • Windows 7
  • Windows 8
  • Windows 8.1
  • Windows 10
Mac
  • MacOS (formerly OS X) 10.11 (El Capitan) or later
Precaution: If you use Dexcom CLARITY, upload your receiver data to Dexcom CLARITY before updating your receiver with the Dexcom Update Tool. Updating your receiver software will permanently erase all stored data from the receiver. If you update your receiver you will not be able to use previous generations of our products, such as the Dexcom G4 or Dexcom G5. Updating your receiver software will reset your alerts and alarm. Consult your Dexcom User Guide for more information related to setting the alerts and alarm. Please note that after updating your Dexcom receiver you will need to re-pair your transmitter. For more information on pairing your transmitter, please click here.

LBL019054 Rev001

Related articles

How do I install the Dexcom Update Tool?

Using the Dexcom Update Tool is similar to doing software updates on your computer. To get the latest software that Dexcom offers, you will first need to install the Dexcom Update Tool.
  • Read More
Privacy PolicyTerms of Use

LBL-1001419 Rev002

LBL019054 Rev001

©

Dexcom, Inc. All rights reserved.

US flag

US

Change Region