Why does the Dexcom G6 app Google Play Store page state, "Your device is not compatible with this version?"

If you’re seeing this message, it means that your phone isn’t compatible with the Dexcom G6 app. As a result, you can’t install the app at this time. You must use a phone listed at www.dexcom.com/compatibility to install the app. These are Android phones that have passed our compatibility testing.
To learn more about what you will see on the Google Play Store once your phone is compatible, view "What will I see in the Google Play Store if my phone is compatible with the Dexcom G6 app?”
To learn more about the Dexcom compatibility process for Android phones, view “How soon will Dexcom support my Android phone?”

LBL022499 Rev001

Privacy PolicyTerms of Use

LBL-1001419 Rev002

LBL022499 Rev001

©

Dexcom, Inc. All rights reserved.

US flag

US

Change Region